Jak już chyba powszechnie wiadomo ;) mam nowy openSUSE 11.2. Po gruntownych porządkach układam sobie ten system od nowa i znów napotkałem na kolejny problem. Autocada 2007 LT trzymam na maszynie wirtualnej, więc by go używać potrzebuję tę maszynę na czymś odpalać, a że zaufałem VMware, więc używam vmplayera (oficjalnie VMware Player).
Jakiś miesiąc temu wyszła nowa wersja – vmplayer 3.0, z całkowicie nową funkcją tworzenia maszyn wirtualnych – polecam.
Instalację zacząłem jak zwykle, z repozytoriów dodając:

  • make
  • gcc
  • źródła jądra, czyli pakiet kernel-source

I tu pojawił się problem, bo po instalacji vmplayer zaczął krzyczeć, że nie może znaleźć pakietu kernel-headers. Szukam – no przecież są zainstalowane… ale co ciekawe w wersji 2.6.31-3.4, natomiast źródła jądra są w wersji 2.6.31.5-0.1. Oczywiście te wersje są także w repozytoriach.

Obejście problemu opisane jest na forum openSUSE, a najkrócej rzecz ujmując, należy zainstalować pakiet kernel-syms, po instalacji którego vmplayer nie ma już zagwozdki z różnymi wersjami jądra i plików nagłówkowych.

Tagged with →  
Share →